Página 2 de 2

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 03 Feb 2019, 11:52
por pakoto
Quiero montar la raspberry sin usar el cable del usb blaster y me he hecho este esquema para aclararme. Tambien aprovecho para agradecer a david el tiempo que ha dedicado a sacar esto.

Imagen

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 01 Sep 2019, 22:28
por Monstronio
Hi All!
I try repeat this addon. But i have some trouble. The menu appears distorted. And the message "can`t open ..." is constantly repeated.
I'm thinking that the bitrate is too big. I tried to change it to 9600, but due to the lack of experience with LINUX, nothing worked for me.

Can anyone do the assembly of "UnAmiga_MultiCore" under the 9600 bit rate?

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 01 Sep 2019, 22:31
por Monstronio
Photos of my device.

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 03 Sep 2019, 09:44
por antoniovillena
Now we use a better solution for multicore thanks to Fernando Mosquera. It's based on STM32 and can be with or without SRAM (for more core compatibility).

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 05 Sep 2019, 00:01
por Monstronio
No pain no gain...

Another problem has surfaced. After a short period of time, the firmwares ceases to be properly loaded. It looks like raspberries are overheating. Which is pretty strange. Recalbox works fine.

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 06 Dic 2019, 01:48
por DaCarSoft
Hi Monstronio,
Apologises for my late reply.

The problem about the distortion on the menu screen looks like is being caused because of some kind of data speed problems, I guess you are having more information in the UART pins than the supported by the Pi Zero.

I guess your colours configuration in NComm may be higher than 4 colours.

You also have to put some "zero" values in the NComm modem configurations as shown in my post or you can try to use the SD images that contains a NComm preconfigured terminal program.

If you really want to change the UART baud speed, you need to change it in NComm and also in the Raspberry Pi config file.

The overheating problem you are experiencing may be caused by your power supply/adapter. If your power source is faulty or not capable of offer enought current for your complete system, then your Pi can fail. You can try with different adapters or even a powerbank, testing for your FPGA and Pi at the same time or to give power only for your Pi (disconnecting the positive power cable and using the microUSB connector).

Try to check your connections, you could have wrong connections that could be overheating your Pi.

Also, it appears your board have the famous "pink" letters colour tone, that looks like the chinese seller tried to "reflow" your FPGA board, and that could be origin of troubles also, because your FPGA current consumption could be higher than the correct comsumption of a properly working board.

Hope this helps. Good luck!

Re: Módulo "add-on" multicore para UnAmiga basado en Raspberry Pi

Publicado: 21 Dic 2019, 14:36
por Monstronio
Hi DaCarSoft!

I can precisely exclude all hardware related issues. But - I have a version of Raspberry Pi without a WiFi module.
The message "can`t open ..." seems to be related to an attempt to initialize the WiFi module.
I think that several unsuccessful attempts to initialize a non-existent hardware leads to fail.